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1. Introduction

1.1 Description

BUGS SCRATCHPAD is a computer program designed to model many of the subsurface
processes in a two-dimensional saturated aquifer. The program models advection and
dispersion, sorption and desorption, biotic and abiotic chemical reactions and
equilibrium conditions. BUGS SCRATCHPAD does this using an operator-splitting
technique coupled with the Linear Integration method to solve the governing equations
of each subsurface process..

BUGS SCRATCHPAD runs under Microsoft Windows 3.1, Windows 95 and
Windows NT.  It provides a straightforward user interface. This interface enables the
user to quickly create small simulations for “back of the envelope” calculations; such as
estimating initial parameters to be used in a larger simulation. In addition, its cut and
paste integration with the Windows clipboard allows for data entry from spreadsheets
for larger, more complex groundwater systems.

This user’s manual describes how to use BUGS SCRATCHPAD. It assumes the reader has
a reasonable understanding of contaminant hydrogeology and its terms; and a working
knowledge of Microsoft Windows. For additional information on how BUGS
SCRATCHPAD solves the set of governing equations, see the BUGS SCRATCHPAD
Technical Reference. For an introduction to contaminant hydrogeology, see
Contaminant Hydrogeology (Fetter, 1994) or a similar text.
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1.2 Organization of this Manual

This manual describes how to use BUGS SCRATCHPAD, to create and run an aquifer
simulation and to view results. If the program has not been installed on the computer
yet, the user should first read Chapter 2, Installation.

New users should read Chapter 3, Elements of an Aquifer Simulation, first. This chapter
explains the program’s conceptual framework and modeling perspective. It describes the
parts that make up a BUGS SCRATCHPAD aquifer simulation.

For those users desiring a guided tour of BUGS SCRATCHPAD, Chapter 13, Examples
and Lessons, is provided. This chapter guides the user through a simple one dimensional
aquifer simulation (as well as other more complicated simulations.) All the necessary
tasks are included in the lessons, no prior knowledge of BUGS SCRATCHPAD is needed.
However, it is recommended to at least read Chapter 3 first.

Chapters 4 through 8 discuss the operational details of BUGS SCRATCHPAD. this
includes file operations, entering and editing reactions, running a simulation, and
viewing output.

For a quick summary of commands available or a description of the menu hierarchy, see
Chapter 10, Menus. This chapter contains a brief description of each menu item and its
action.
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2. Installation
In order to install and run the BUGS SCRATCHPAD, the computer must be an IBM
compatible 386 or higher computer. There must be at least 2.5 Mbytes of free disk space
for installation of the program. This excludes the space required for simulation files.
BUGS SCRATCHPAD uses Microsoft Windows operating system environment.

To install BUGS SCRATCHPAD, follow these procedures:
• Start Microsoft Windows if not already running.

• Quit any running applications in Windows
(Setup may interfere with these programs)

• Insert Disk 1 of the BUGS install disks into drive A: or B:

• From the Program Manager Select Run from the File Menu
or Run from the Taskbar Start Menu for Windows 95 or NT.

• Type “a:\setup” at the prompt (or the location of the setup program.)

• Follow the instructions provided by the setup program.
(For Windows 3.1 installations, choosing an install directory
other than the provided default requires extra steps described below)

BUGS SCRATCHPAD should now be installed and ready to run.

Windows 3.1 Installation Note: The setup program provides a default application
directory for installation. If a directory other than this default is chosen, the
“BCOMP.PIF” file must be modified. The application and working directory in
BCOMP.PIF must be changed to reflect the non-default application directory. This file
can be edited with the PIF editor provided by Windows 3.1 . (BCOMP.PIF resides in
the application directory.)  This does not apply if the Windows 95 or Windows NT
installation is chosen.
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3. Elements of an Aquifer Simulation
 BUGS SCRATCHPAD uses three principal components to represent an aquifer system.
They are the aquifer, parameters, and reactions. The aquifer refers to the discretized
representation of the aquifer; its size and shape, and mesh properties. Parameters refer to
the value of properties at a node such as the value of hydraulic head or hydraulic
conductivity. Parameters can also refer to the concentration of various solutes or sorbed
species at a given node. Reactions are means by which values of components change,
such as desorption of a sorbed phase to a solute phase, first order decay, or reduction in
hydraulic conductivity due to biomass growth.

In addition to these three principal building blocks, other components aid the
organization of data and simplify editing. They can be thought of as container objects,
such as the Reaction System, which refers to a collection of reactions. Also, one can
define a name which refers to a point in the aquifer, known as an Alias.

3.1 The Aquifer

Although, an aquifer is usually a continuous body with the porosity conductivity varying
as such; it is necessary to represent an aquifer in discreet terms for BUGS to understand
it. BUGS divides the aquifer into discrete elements or cells. It assumes the material
properties and concentrations are assumed to be constant throughout each element, but
are allowed to differ between separate elements. In this way the program represents a
non-homogeneous aquifer as a collection of different homogeneous regions.

BUGS can simulate one and two dimensional aquifers. The coordinate system is limited
to the Cartesian coordinate system. Elements are rectangles and are node centered. Node
centered means the element is defined by a node which is located at the center of the
element. Figure 3.1 depicts a “5 X 4” aquifer mesh.
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Node (1,4)

Node (1,1)

Node (5,4)

Figure 3.1 Illustration of a 5 x 4 Aquifer Mesh

Element boundaries reside halfway between nodes. Width of boundary elements equal
the distance between the boundary node and its neighbor. If a node lies on an aquifer
boundary, it is assumed to be a no-flow, no-flux boundary unless otherwise modified by
the user.

The amount of data required to properly represent an aquifer at minimum is the number
of nodes in both the X and Y dimensions, and their coordinates.

3.2 Parameters

BUGS Scratchpad recognizes three types of parameters; system, mobile, and immobile
parameters. It requires the system parameters to represent the most basic of aquifer
systems. System parameters include hydraulic head, hydraulic conductivity, and
material porosity. They are defined at every node in the aquifer and can not be deleted or
added by the user. However, a user can alter initial values and relationships though
reactions.

Parameters that are added and deleted by the user are mobile and immobile parameters
(collectively referred to as user parameters). Mobile parameters are, as the name
implies, mobile. These parameters have advection and dispersion properties. They are
usually solutes in the fluid (usually water) that saturates the aquifer. Transport processes
and reactions change mobile species concentration at nodes. Immobile species
concentrations are only changed by reaction processes.

The minimum amount of data required to represent most parameters is the initial value
at each node. This can be done by specifying a default concentration, or by explicitly
specifying it at every node. In addition to the initial value, mobile parameters require the
definition of dispersivity and diffusion coefficients.
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3.3 Reactions

Reactions are a very important part of a aquifer system. They manipulate values of
parameters as a function of time and other parameters. (Mobile parameters are also
manipulated relative to space and time as a function of their advection-dispersion
properties.) There are two types of reactions, equilibrium and kinetic.

Equilibrium reactions are instantaneous while kinetic reactions are rate limited. Each
reaction requires two types of data; rate data (for kinetic), rule data (for equilibrium) and
Stoichiometry data. For example consider the equilibrium reaction:

2 = A
B

(3.1)

Equation (3.1) states the ratio of parameter A to Parameter B must always be two.
Setting this rule alone is insufficient. It is necessary to tell BUGS how these two
parameters relate to each other so  the adjustment can take place (and the mass balance
preserved). An example of the stoichiometry corresponding to equation (3.2) is:

A B↔ 2 (3.2)

With the stoichiometry relationship, BUGS will know how much of A appears when B
disappears, or the opposite. This is similar for kinetic reactions. Consider the Reaction:

A Brate → 2 (3.3)

rate A= 2 (3.4)

Equation (3.3) proceeds forward at the rate specified by equation (3.4).

BUGS SCRATCHPAD recognizes many different types of Equilibrium and Kinetic
Reactions, including: Equilibrium, Ordered, Monod, Competitive Inhibition, Linear
Isotherm, Fedulich Isotherm, and Langmuir Isotherm. Also, a rule curve reaction is
included for special cases. Specific information on each reaction can be found later in
this document.

It should be noted that BUGS SCRATCHPAD does not use any particular set of units in its
simulation. Units are assumed to be “consistent”. The user has to make the conversions
from mass to moles if necessary.

3.4 Reaction Systems

Reaction systems are simply a means of specifying a certain group of reactions which
occur at a specific node. Each node in the aquifer has a reaction system assigned to it. In
this way, reactions can be allowed to occur at certain nodes (such as a well) and not
others.
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3.5 Alias

Aliases are an alternate way to specify a node. It can be thought of as giving a node a
name. Aliases are not necessary, just a convenience for navigating through large
aquifers.
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4. File Operations
Before the discussion of file operations, it is necessary to give a brief overview of the
files used by BUGS. The following table shows the extensions associated with a BUGS
project:

Table 4.1 Files used by Bugs

Extension Description

.bgs BUGS Database File. It contains all the information associated with constructing an
aquifer simulation. Typically this is the only file the user will interact with.

.bgi Simulation routine input File. It contains a numerical representation of the aquifer.
BUGS creates it prior to calling the simulation routine. (ASCII Format)

.bgo Simulation Routine Output file. These file contain the value profiles of parameters
in the aquifer as a function of time. It is written by the simulation routine. (Binary
Format)

.bgt Simulation time file. It contains a list of the simulation time periods written to disk.
It is written by the simulation routine. (Binary Format)

Typically only *.bgs files will be seen by the user. BUGS automatically handles the
others.

BUGS can only open one project at a time. To create a new project, simply select New
from the File menu. To save a BUGS file to disk, chose the Save command from the
File menu. If a new project has not been previously saved to disk, the user will be
prompted for a filename. A project can be also saved with a new file name by using the
Save As command from the File menu. For more information on the File menu, see the
section on menus later in this document.
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5. About Grid and Form Views
BUGS provides two formats for entering and editing data, “Form” and “Grid” views. A
“Form” view of a window usually displays information for one item at a time. This can
be quite useful, however it does limit the user to viewing a small part of the system at a
time. For one who is most comfortable working in a spreadsheet-type environment,
BUGS provides a “Grid” view. The grid view typically shows lists of items in the
window. It should be noted that sometimes it would not be logical to show certain
information on a grid, and the same for the form view. Some information may only be
accessible through a certain view, such as a list of node coordinates.

It is easy to switch between views of a window. If the user wishes to see the form view,

they can either click on the  button on the tool bar or select Form from the View

menu. If the user desires to see the grid view, they can select the  button on the tool
bar or select Grid from the View menu. If the desired views available, it is because the
current information cannot be displayed in that type of view.
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6. Editing an Aquifer System
BUGS is a flexible program that allows the user many options in editing. This section is
organized by desired task to be accomplished. For a sequential look at available
commands, see Chapter 9, Communicating with Other Programs.

6.1 Setting Simulation Times

To edit the starting and editing times of a simulation, select Aquifer Properties from the

Window Menu, then select the form view of the window by selecting the  button
from the tool bar or selecting Form from the View menu. This will bring up the Aquifer
Properties window as shown in Figure 6.1.

Simulation Starting Time

Simulation Ending Time

Results Printing Interval

Default Reaction System
for All NodesDefault Grid Spacing

in the Y direction

Default Grid Spacing
in X direction

Number of Nodes in
the X direction

Number of Nodes
in the Y direction

Figure 6.1 Aquifer Properties Window in Form View

The values of interest to be changed are the starting time, ending time, and printing
time. Starting and ending times have no limits except for the ending time which must be
greater than the starting time. The printing time is the time increment in which the
simulation routine writes parameter profiles to intermediate files. A smaller print time
will give a higher resolution in output with respect to time, at the cost of increased disk
space usage. From this window the user can also edit the aquifer shape and size.

6.2 Aquifer Size and Discretization

In the aquifer properties window (Form View, See Figure 6.1) the user can change the
number of nodes in the X and Y directions. The default node spacing can also be
changed. It should be noted that the default grid spacing is only used when the aquifer is
growing, or in other words, the user specifies a larger number of nodes. Also, the
aquifer properties window gives the user a chance to specify the default reaction system.

The form view of the Aquifer Properties window does not allow the user to customize
the grid spacing of the aquifer mesh. In order to do this, it is necessary to view the
Aquifer Properties Grid.
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6.3 Customizing the Aquifer Mesh

To edit aquifer node grid spacing, select Aquifer Properties from the Window menu.

Then select the Grid View button  on the tool bar or select Grid from the View
Menu. The active window should now appear as in Figure 6.2

Number of Nodes
in the Y direction

List of coordinate
values in the Y
direction

Number of Nodes
in the X direction

List of Coordinate
values in the X
direction

Figure 6.2 Aquifer Properties Window in Grid View

From Here, the user can edit the placement of various nodes in the X and Y directions.
The editing tables support the windows copy and paste functions. It should be noted that
it is necessary for the node coordinates to be in increasing order. That is, xi < xi+1. This is
necessary for proper simulation, BUGS cannot simulate an overlapping aquifer.

6.4 Adding and Removing Parameters

Only two of three types of parameters can be added and deleted; mobile and immobile
parameters, or otherwise called user defined parameters. System parameters are required
for computing the hydraulic flow field. Although system parameters cannot be added or
deleted, their initial values can be changed at the discretion of the user.

To add a parameter to the aquifer system, the Parameters window must be open. To
open the window, select Parameters from the Window Menu. If necessary, click the

Form view button  on the tool bar, or select Form from the View menu, to bring up
the form view of Parameters.
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List of
Parameters, the
selected is the
current

Default Initial Value

Current Node in
X direction

Current Node in
Y direction

Remove the
currently selected
parameter

Mobile Parameter
Check Box

Longitudinal
Dispersitivity

Mollecular
Diffusion
Coefficient

Transverse
Dispersitivity

Inital value of
parameter
(overides default)

Figure 6.3 Parameters Window in Form View

Figure 6.3 illustrates the Parameters Window. To add a parameter, check on the Add
Button. A dialog box will appear requesting the name of the new parameter.

Add the New Paramter
Exit without adding the
new Parameter

Name of Parameter to be added.

Figure 6.4 Add Parameter Dialog Box

Parameters must have unique names. If the user specifies a name that already exists, a
new parameter will not be added to the system.

To delete a parameter from the system, simply select the parameter form the list of
names and click on the remove button. One should note this is an irreversible process. It
can not be undone. All references to this parameter will be removed. If the remove
button is not enabled, it is because the selected parameter is a system parameter, which
can not be deleted.

6.5 Specifying Mobile and Immobile Parameters

User defined parameters can be specified to be mobile or immobile. Immobile
parameters can represent entities such as a sorbed species or ionic strength of the
solution at a node. To specify an immobile parameter from the list of parameter names,
activate the Parameters Window in Form View (discussed above), select the desired
parameter, and clear the Mobile check box located below the list of parameters.
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To specify a user defined parameter as mobile, check the mobile check box. When this
option is checked, three edit boxes will appear. These boxes allow the user to edit the
longitudinal dispersivity, transverse dispersivity and diffusion coefficient. For a further
discussion of these parameters, see the BUGS SCRATCHPAD Technical Manual.

6.6 Specifying Initial Values of Parameters

There are two ways to specify the initial value of a parameter (the value at the beginning
simulation time). First, the user can specify the default initial value for the parameter.
This default value can be overridden by setting the value at a given aquifer node
explicitly. To specify the default initial value of a parameter, the parameters window in
form view must be active. (discussed above) the “Co” field corresponds to the default
initial value of the parameter at every node unless overridden by the method described
below.

There are three ways in which the user can override the default initial values of a
parameter. The first way is to use the Form View of the parameters window described
above. In the frame called Initial Values (see Figure 6.3 above) the user can specify the
node coordinates and initial value of the parameter for the specified node. The second
method involves a similar interface contained in the form view of the nodes window (to
be discussed later).

The third way to explicitly define initial parameters is to use the grid view of the nodes
window. To activate the nodes window in grid view, Select Nodes from the Window

menu and click on the  button on the tool bar or select Grid from the View menu.
Figure 6.5 illustrates the window.

Current Parameter Y Node number and Coordinate

X Node Numbers and Coordinates Inital Parameter Values

Figure 6.5 Nodes Window in Grid View

In this way the user can enter the initial values in a spreadsheet like manner. BUGS
supports the windows clipboard cut, copy and paste commands. Thus, initial values can
be imported from other programs via the clipboard. For more information on using the
clipboard with bus, see Chapter 9, Communicating with Other Programs.
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6.7 Editing Reactions

BUGS hosts a large suite of reactions found in many aquifers. Since reactions are the
most important part of the BUGS implementation, they are also the most difficult to
explain.

Reactions are used in a variety of ways. They are serve as rules defining how mass
transfer between parameters occurs. For example, sorption of methane to aquifer solids
is an example of a linear isotherm reaction. A more complicated example would be
consumption of methane and oxygen by a concentration of methanotrophs producing
carbon dioxide using a double Monod relationship. Cometabloism of TCE and
intermediate toxicity effects of TCE-Epoxide could affect methane consumption, not to
mention biomass growth and decay. One can see how a set of individually simple
equations can couple together to produce a highly nonlinear aquifer system. This section
describes how simple components combine together to form the complex system that
BUGS can understand.

6.8 Opening the Reactions Window

The Reactions Window can only be seen in the form view. To open the Reactions
window select Reactions from the Window menu. Figure 6.6 illustrates the initial view
of the Reactions Window

Add a new reaction

Remove Selected Reaction

List of Reactions

Figure 6.6 Reactions Window

If the aquifer system does not contain any reactions yet, the user will first be prompted
to enter a name for the first reactions to be added to the aquifer system.
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6.9 Adding and Removing Reactions

To add a reaction to the aquifer system first display the Reactions Window (as discussed
above). When the reactions window opens for the first time, there will be no reactions in
the aquifer system. The user will be automatically prompted to enter a name for a new
reaction. Figure 6.7 shows the add reaction dialog box

Add New Reaction
Exit without Adding
Reaction

Name of Reaction to be added

Figure 6.7 Add Reactions Dialog Box

Simply type in the name of the reaction and press ENTER on the keyboard or click the
OK button. To add additional reactions, click on the Add button in the reactions
window and follow the above procedure again. Reaction names must be unique. If the
user specifies a name already used by a reaction, no reaction will be added to the
system.

To remove a reaction, select the reaction name to be deleted in the name list box and
click the remove button. If only one reaction exists, the remove button will not be
enabled. Each Aquifer system usually should have at least one reaction. Removing a
reaction is an irreversible process, all references to the reaction will be removed.

6.10 Setting the Reaction Type

With the reactions window open, click on the type tab This will display the various
reaction types. Figure 6.8 illustrates the “Type” page for the reactions window.

Edit Reaction Types Tab

Figure 6.8 Reactions Window for Editing Reaction Type
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The user can select a type of reaction by simply selecting the desired option button. A
discussion of the various reaction types is explained later in this section

6.11 Setting the Stoichiometry of a Reaction

 As mentioned earlier, most reactions require the user to explicitly define reaction
stoichiometry. With the Reactions window open in Form View, select the Stoichiometry
tab. Figure 6.9 depicts the corresponding window

Edit Stiometry of a Reaction Tab

List of
parameters
and
associated
stoichiometry
magnitudes

Equation of stiometry printed by BUGS

Figure 6.9 Reactions window for Editing Reaction Stoichiometry

To specify the magnitude for a parameter in a Stoichiometry reaction, enter the
magnitude in the grid next to the desired parameter. Negative values will place the
parameter on the left side of the arrow while positive numbers are placed on the right.
The Stoichiometry reaction as understood by BUGS is echoed in the Stoichiometry box.
It is important to specify the order correctly with kinetic reactions. The reaction will
proceed to the right by the rate specified in the rate data (to be discussed later). For
Equilibrium reactions the order of reaction is not important, just the mass balance.

6.12 Specifying a Reaction System for a Reaction

Before a reaction can be used by BUGS, it needs to be included in a reaction system.
The Reaction System in turn is specified at a node. This is the way in which BUGS
assigns which reactions occur at each node.

With the Reactions Window open in Form View, select the Reaction Systems Tab
Figure 6.10 illustrates the corresponding screen.
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Link and Unlink Reactions and Reaction Systems Tab

List of
systems
that
include
selected
reaction

Link and unlink buttonsList of systems that do not
include selected reaction

Figure 6.10 Reactions Window for Choosing Reaction Systems

This screen allows the user to select which reaction systems include this particular
reaction. It can be seen from Figure 6.10 that reaction 1 is included in Reaction Systems
1 and 3, but not 2. Reaction Systems 1 and 3 include Reaction 1. To link Reaction with
a Reaction System, select the reaction in the Not Contained In list and click the 
button (or simply double click the system). To remove the link, select the system in the
Contained In list and click the  (or double click on the system). To unlink all
systems click the  button and to link all systems click the  button.

6.13 Specifying Reaction Rate Data

To edit the rate or rule data for a reaction, the user must bring up the rate data editing
page for the reaction. This is the same regardless of the reaction type. First the Form
View Reactions Window must be active. Then select the rate data tab. BUGS supports
many different types of reactions. Each reaction appears in a different screen. This
section illustrates how to enter rate or rule data for each type of a Reaction.
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6.13.1 Equilibrium Equation

Equilibrium Constant

Powers of ParametersEcho of Equation

Figure 6.11 Equilibrium Reaction

The equilibrium reaction adjusts the values of parameters given in the Stoichiometry
relationship (if possible) such that the ratios of their values match the equilibrium
constant.

6.13.2 Equality Equation

 

Dependent Parameter

Parameter Coefficients

Constant
Coefficient

Echo of Equation

Figure 6.12 Equality Reaction

The equality reaction simply sets the dependent parameter to the value specified by the
linear combination of parameters and constant.
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6.13.3 Single Order Reaction Equation

Rate Coefficient Order

Driving Parameter

Figure 6.13 Single Order Reaction

The single order reaction only uses data from one parameter to determine the rate of
reaction.

6.13.4 Mixed Ordered Reaction Equation

Rate Coefficient

Parameter PowersEquation Echo

Figure 6.14 Mixed Ordered Reaction

The mixed order reaction uses values of multiple parameters to determine the rate of the
reaction.



23
6.13.5 Linear Equilibrium Isotherm

Sorbed Species Solute Species

Porportionality Constant

Figure 6.15 Linear Equilibrium Isotherm

The linear equilibrium sorption isotherm adjusts parameters using the relationship
defined in the Stoichiometry to set the left hand side of the equation equal to the right
hand side.

6.13.6 Langmuir Equilibrium Isotherm

Sorbed Species Solute Species

Porportionality Constant Porportionality Constant

Figure 6.16 Langmuir Equilibrium Isotherm

The Langmuir Equilibrium sorption isotherm adjusts parameters using the relationship
defined in the Stoichiometry to set the left hand side of the equation equal to the right
hand side.
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6.13.7 Fredulich Equilibrium Isotherm

Sorbed Species Solute Species

Porportionality Constant Exponent

Figure 6.17 Fredulich Equilibrium Isotherm

The Fredulich Equilibrium sorption isotherm adjusts parameters using the relationship
defined in the Stoichiometry to set the left hand side of the equation equal to the right
hand side.

6.13.8 Linear Kinetic Isotherm

Rate Constant Sorbed Species

Solute SpeciesPorportionality Constant

Figure 6.18 Linear Kinetic Isotherm

The linear kinetic isotherm computes a target sorbed phase concentration with the linear
isotherm relationship. A mass transfer equation is then used to determine the rate of
reaction.
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6.13.9 Langmuir Kinetic Isotherm

Rate Constant Sorbed Species

Porportionality Constants Solute Species

Figure 6.19 Langmuir Kinetic Isotherm

The Langmuir Kinetic isotherm uses the Langmuir isotherm relationship to compute a
target sorbed phase concentration. A mass transfer equation is then used to determine
the rate of reaction.

6.13.10 Fredulich Kinetic Isotherm

Rate Constant Sorbed Species

Porportionality Constant

Power

Solute Species

Figure 6.20 Fredulich Kinetic Isotherm

The Fredulich Kinetic isotherm uses the Fredulich isotherm relationship to compute a
target sorbed phase concentration. A mass transfer equation is then used to determine
the rate of reaction.
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6.13.11 Single Monod Equation

Rate Constant Substrate

Biomass Half Saturation

Figure 6.21 Single Monod Reaction

The Single Monod equation relies on values from two parameters to determine the rate
of reaction. However, the biomass portion can be ignored by setting to “unity”.

6.13.12 Double Monod Equation

Rate Constant

Biomass
Substrates

Half Saturation

Figure 6.22 Double Monod Reaction

The Double Monod equation relies on three parameters to compute the rate of reaction,
two substrate and one biomass. If the biomass component is not needed, it can be set to
“unity”.
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6.13.13 Competitive Inhibition Equation
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Figure 6.23 Competitive Inhibition Reaction

The Competitive Inhibition equation includes a term for a competitive parameter in one
of the substrate terms of a double monod relationship. If the biomass term is not needed,
it can be set to unity.

6.13.14 Mass Transfer Equation

Rate Coefficient

Driving Parameters

Figure 6.24 Mass Transfer Reaction

The mass transfer equation simply uses the difference between two parameter values to
compute the rate of reaction.
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6.13.15 Rule Curve Reaction
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Figure 6.25 Rule Curve Reaction

 The Rule Curve reaction can be used if all of the above reactions were not appropriate.
In addition to accessing the values of parameters, this reaction can also use time as
input. For example, an injection schedule could be entered. Independent variables (x)
must be entered in acceding order. BUGS uses a simple lookup routine to find values in
the list.

6.14 Opening the Reaction Systems Window

 Reaction systems can be thought of as collections of reactions. This is necessary
because not all subsurface processes may occur everywhere in the aquifer. For example,
a well in an aquifer may be injecting methane at a constant concentration. This process
only occurs at the well. Thus, the user can specify a reaction describing a constant
source, and group it in a “well” reaction system. This reaction system in turn could be
assigned to the node at the location of the well.

The Reaction Systems window has only one view, form views. To open the reaction
systems window select the Reaction Systems from the Window menu. Figure 6.26
illustrates the corresponding window.
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Figure 6.26 Reaction Systems Window

If the aquifer system contains no reaction systems, the user will be automatically
prompted to enter a name for the first reaction system.

6.15 Adding and Deleting Reaction Systems

To add a reaction system, first display the reaction systems window (as discussed
above). When the reaction systems window opens for the first time, there will be no
reaction systems. The program automatically prompts the user to enter a name for a new
reaction system. Figure 6.27 shows the add reaction systems dialog box.

Figure 6.27 Add Reaction Systems Dialog Box

Simply type the new name of the reaction and press ENTER or click on the OK button.
To add additional reaction systems, click on the Add button in the reaction systems
window and follow the above procedure. Reaction system names must be unique. If the
user specifies a name already used by a reaction system, no reaction system will be
added.

To delete a reaction system, simply select the desired system in the reaction system list
box, and click on the remove button. If only one reaction system exists, the remove
button will not be enabled. Each aquifer system must have at least one reaction system.
Deleting a reaction system is an irreversible process. It can not be undone.
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6.16 Specifying a Reaction for a Reaction System

Figure 6.26 above depicts a typical aquifer system. The aquifer system has available to it
a source pool of three reactions. It can be seen from the figure that reaction system 1
includes reactions 2 and 3, but not reaction 1.

To add a reaction to the reaction system, simply select the reaction to be added in the
“available” list and click the  button. To remove a reaction from a reaction system,
select the reaction from the “included” list and click on the  button. To include or
exclude all reactions click on the  or  buttons respectively. A shortcut to the 
and  buttons is to double click on the reaction.

6.17 Specifying the Default Reaction System

 To specify the default reaction system to occur at all nodes in the aquifer system, select
the desired reaction system in the reaction system window. Then check the “use as
default system” check box. This system will now be used by all nodes unless otherwise
overridden from the nodes window as discussed earlier.

6.18 Changing Simulation Run Options

To change simulation run options, select Options from the Run menu. The following
dialog box will appear.

Figure 6.28 Simulation Run Options Dialog Box

Two simulation run options can be changed, the global calculation timestep and the
operational definition of zero. The simulation routine uses the global calculation
timestep to calculate advection and dispersion of mobile parameters. It is not
recommended to override the automatic calculation of this variable. See the BUGS
SCRATCHPAD Technical Reference for details on the calculation of the timestep.

The operational definition of zero can be thought as a tolerance factor in the iterative
calculation of kinetic and equilibrium reactions. The higher the value, the faster
simulations will run, but they will be less accurate.
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7. Running a Simulation
After all the necessary data has been entered for an Aquifer System, the System can be
simulated. To run the simulation, select Simulate from the Run menu When this option
is selected, BUGS shows a dialog box describing the progress of the simulation. The
user can not edit the aquifer system while the simulation is being run.
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8. Viewing Output
After a simulation has been run or updated, the user has four output options. The user
can view a profile of parameter values in a snapshot of time. Additionally, the user can
view parameter values as a function of time at a given node in the aquifer. BUGS also
produces a surface graph of parameters. Finally, numerical output can be viewed in a
tabular format.

8.1 Parameter Profile Graph

Parameter profile graphs consist of a snapshot in time of parameters along a profile in
the X or Y direction. To view a profile graph, select Profile Graph from the Windows
menu. If the simulation is out of date with respect to the current input parameters, the
user will be prompted to update it.

Scroll bar used to
select time

Simulation
time edit
box

Coordinate
intercept
value

Profile
direction
toggle

Figure 8.1 Parameter Profile Graph

Profile graphs can display more than one parameter at a time. In order to add or remove
a parameter from the graph, select the desired parameter from the Parameters menu. If
the menu does not display the desired parameter, select the More ... command. A dialog
box with a list of all the parameters to chose from will appear.

A profile graph can only be displayed in the X or Y direction. To toggle the orientation
of the graph, click on the   or  button for a profile in the X or Y direction
respectively.

If the profile plot is oriented in the X direction, the coordinate intercept value refers to
the point in the Y direction which the X profile passes through. The opposite is true for
Y profile graphs.

The user can change the time of the profile plot in two ways. The easiest way is to use
the scroll bar to quickly scan through the time periods for the desired time. The user can
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also enter a time directly in the time edit box, the closest matching time period will be
displayed.

8.2 Node Time Series Graph

Node time series graphs consist of a plot of parameters at a fixed point in the aquifer
over the time period of simulation. To view a node graph, select Node Graph from the
Windows menu. If the simulation is out of date with respect to the current input
parameters, the user will be prompted to update it.

X Coordinate Y CoordinateAlias Name

Figure 8.2 Node Profile Graph

Node graphs can display more than one parameter at a time. In order to add or remove a
parameter from the graph, select the desired parameter from the Parameters menu. If the
menu does not display the desired parameter, select the More ... command. A dialog box
with a list of all the parameters to chose from will be displayed.

To change the node location, the user can use the X and Y coordinate edit boxes, or
select the node name form the alias list.

8.3 Surface Plot

For the individual that prefers to see a larger picture than just a profile or time series at a
particular point, BUGS can generate surface plots over the entire aquifer for a given
parameter at a given point in time. To view a surface plot, select Surface Graph from the
Window menu.
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Simulation time scrol barSimulation time edit box

Figure 8.3 Surface Plot

The user can change the time of the profile plot in two ways. The scroll bar can quickly
scan through the time periods for the desired time. The user can also enter a time
directly in the time edit box, the closest matching time period will be displayed.

8.4 Tabular Output

The most useful output feature provided by BUGS is the tabular output table. The
numbers in this table can be transferred to other programs via the clipboard. To view the
output grid, from the Windows menu, select Output. Figure 8.4 illustrates a typical
output screen.

Figure 8.4 Numerical Output
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The output grid can display information in any desired format or configuration. If the
user desires time displayed in columns instead of Y coordinates, they simply need to
position the mouse pointer over the Time caption, press down on the left mouse button,
move the mouse pointer to the Y axis caption while keeping the button depressed, then
release the mouse button. (This is also called Drag and Drop.) The corresponding
window would then look like Figure 8.5.

Figure 8.5 Adjusted Numerical Output

In this way the output can be configured to the user’s needs.
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9. Communicating with Other Programs
This chapter describes how BUGS  can exchange data with other programs. The primary
way to exchange data is through the windows clipboard. However, the output files can
be accessed directly when the use of the clipboard would be cumbersome or
inappropriate. BUGS does not currently support Dynamic Data Exchange (DDE) or
Object Linking and Embedding (OLE).

9.1 The Windows Clipboard

Currently, BUGS supports the windows clipboard cut, copy, and paste commands. The
clipboard commands are found on the Edit menu. In addition to the edit menu, the user
can use the shortcut keys Ctrl-X, Ctrl-C, and Ctrl-V for cut, copy, and paste
respectively. These commands work with most text edit boxes, combo boxes, and
editing grids. The utility of these commands can be easily seen with the use of editing
grids. For example, say the user has a spreadsheet depicting the current concentrations
of contaminant in an aquifer. The user needs to enter these initial concentrations into
BUGS. Instead of entering the concentrations by hand, the user can use the copy and
paste commands. Simply copy the values to the clipboard in the spreadsheet program,
then switch to bugs, bring up the nodes window in grid view, select the contaminant and
then use the paste command. The initial conditions are entered.

Not only can initial conditions be entered via the clipboard, output data can also be
transferred. For example, if the user has a superior graphing package to that supplied by
BUGS. The numerical values could be copied from the output grid and pasted into the
graphing software.

9.2 Output File Format

In the case where use of the clipboard is too cumbersome or repetitive, the output file
themselves can be accessed. The files are in binary format. The concentration file
contains a stream of eight byte floating point numbers..

The numbers are grouped first by the parameters at a node first, then rows  of nodes in
the Y direction, followed by rows of nodes in the X direction, then time. For example, if
the aquifer was the size of two nodes in both the X and Y directions with two
parameters spanned over two time periods, the order of values would be:
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Table 9.1 *.bgo Output File layout

Parameter Y Coordinate X Coordinate Time Period
1 1 1 1
2 1 1 1
1 2 1 1
2 2 1 1
1 1 2 1
2 1 2 1
1 2 2 1
2 2 2 1
1 1 1 2
2 1 1 2
1 2 1 2
2 2 1 2
1 1 2 2
2 1 2 2
1 2 2 2
2 2 2 2

Future versions of BUGS may include export utilities that will port to multiple formats.
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10. Menus
This chapter is presents a chronological listing of the commands available through the
menu structure. They are listed in chronological order. For a discussion on a particular
task to be accomplished, see Chapter 6, Editing an Aquifer System.

10.1 File Menu

The file menu contains commands associated with file operations such as loading,
saving, and printing files.

New Creates a new simulation file. If the current simulation has been changed
since the last time it was saved, the user will be prompted to save it before
creating the new simulation file.

Open Opens a previously saved simulation file. If the current simulation has
been changed since the last time it was saved, the user will be prompted to
save it before opening the simulation file

Save Saves the current simulation to disk under the present name.

Save As Saves the current simulation to disk under a new file name.

10.2 Edit Menu

 The edit menu contains the clipboard cut, copy and paste commands.

Cut Instructs BUGS to copy the currently selected item to the clipboard and
erase it. This command may not always be available.

Copy Copies the currently selected item to the clipboard. This command may not
always be available.

Paste Places the current contents of the clipboard onto the selected item.
Depending upon what is in the clipboard and what is selected, this
command may not be available.
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10.3 View Menu

This menu allows the user to change certain aspects of the working environment and
types of screens shown.

Toolbar Displays the toolbar below the menu bar. For more information on the
toolbar, see the following chapter.

Status Bar Makes the status bar visible at the bottom of the BUGS window. The
status bar is a source of additional information to the user.

Form Shows the form view of the active window. Depending on the currently
active window, this command may not be available.

Grid Displays the grid view of the active window. Depending on the currently
active window, this command may not be available.

10.4 Run Menu

This menu allows the user to set simulation run time options and to run the simulation.

Simulate Runs a simulation. It is only available if the simulation has been saved to
disk.

Options This command brings up a dialog box that allows the user to override the
default global time calculation and to set the value of the operational
definition of zero.

10.5 Parameters Menu

If this menu is visible, it allows the user to select a parameter from the list of available
parameters. Depending on the active window, multiple parameters may be selected at a
time. A check denotes a selected parameter. If there are more parameters than can be
displayed on the menu, the More... command will be visible. Selecting this command
will show a dialog box containing a list box of all the parameters to chose from.
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10.6 Window Menu

Tells BUGS to display the various editing and output windows.

Aquifer
Properties

This window allows the user to edit the size of an aquifer, grid spacing,
starting and editing times, and the default reaction system.

Parameters Displays a window which can add and remove parameters, edit parameter
dispersion properties, and specify initial values.

Nodes Displays window which specifies prescribed heads, placement of reaction
systems, and edits parameter initial values.

Reactions Displays a window which can add and delete reactions, specify reaction
types, edit rate data, edit Stoichiometry data, and to link and unlink
reactions and reactions systems.

Reaction
Systems

Displays a window which can add and remove reaction systems and to link
and unlink reactions and reaction systems.

Profile
Graph

Displays a graph of parameters in a cross-section through the aquifer at a
snapshot in time. This window is only available if the simulation is current
or up to date.

Node
Graph

Displays a graph of parameters at a give node over the time of simulation.
This window is only available if the simulation is current or up to date.

Surface
Graph

Displays a surface plot of a parameter throughout the aquifer at a given
time. this window is only available if the simulation is current or up to
date.

Output Displays a configurable grid of output values. By using drag and drop, the
grid can be configured for the display desired by the user. This window is
only available if the simulation is current or up to date
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11. Toolbar
The toolbar can be used as a shortcut to the menu system. The commands are carried out
by simply clicking on the appropriate toolbar button. The standard BUGS toolbar is
shown in Figure 11.1

Figure 11.1 BUGS Toolbar

The following is a description of the options.

New creates a new BUGS simulation file

Open opens an existing BUGS simulation file

Save saves the current BUGS simulation file

Form  switches the active window to form view

Grid switches the active window to grid view



42

12. Command Keys
Some of the menu commands also have corresponding command keys, or shortcut keys.
Table 12.1 lists the actions and associated command keys. “Ctrl” refers to the control
key, “Alt” refers to the Alt key. The hyphen means to press the two keys
simultaneously. For example, Ctrl-X means to hold down the Ctrl key and press the X
key.
Table 12.1 Command Keys

Task Key
Open Ctrl-F12
Save Shift-F12
Save As F12
Cut Ctrl-X
Copy Ctrl-C
Paste Ctrl-V
Run Simulation F5
Exit Alt-F4
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13. Examples and Lessons
The purpose of this chapter is to give the user hands on experience in BUGS
SCRATCHPAD. These step-by-step instructions will guide the user in quickly creating an
aquifer simulation and viewing the results. It is recommended the user follow along
with these lessons on the computer. However, this is not absolutely necessary as, all
relevant pictures are included in the text.

Currently there are four lessons in this chapter, each is designed to build on the previous
lesson. Lesson One shows how to create a one dimensional solute transport simulation
using a conservative solute with a constant source at the inlet. Lesson Two adds kinetic
sorption to the simulation. Lesson Three adds a first order decay reaction and Lesson
Four expands the simulation to two dimensions. The lessons in this section provide a
brief overview of some of the tools provided by BUGS SCRATCHPAD. Complete
descriptions of all the tools were discussed in previous chapters.
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13.1 Lesson 1, Conservative Solute Tracer Simulation

 This tutorial will step through the tasks necessary to create a one dimensional, constant
source conservative solute tracer simulation. The following table presents the input
parameters in this tutorial.

Parameter Value Units

Aquifer Length 100 meter

Grid Spacing 1 meter

Starting Time 1 day

Ending Time 10 day

Output Timestep 1.0 day

Longitudinal Dispersitivity 1.0 meter

Transverse Dispersitivity 0.1 meter

Effective Diffusion 0.0 sq.meter/day

Constant Inlet Concentration 10.0 mg/l

Effective Porosity 0.5 cu.meter/cu.meter

Pore Water Velocity 2.0 meter/day

Roughly speaking, conducting this BUGS  SCRATCHPAD simulation can be divided into
10 steps:

1. Starting the Program

2. Defining the Grid Mesh

3. Adding the Conservative Solute

4. Creating the Boundary Condition "Reaction"

5. Creating the Reaction Systems

6. Assigning Reaction Systems to Nodes

7. Setting the Hydraulic Flow Conditions

8. Saving the Simulation Project File.

9. Running the Simulation

10. Viewing Results

These steps are described below:
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1. Start BUGS SCRATCHPAD.

To start BUGS SCRATCHPAD, either double click on the program icon (Windows
3.1) or select BUGS SCRATCHPAD from the Start Menu -> Programs -> BUGS
SCRATCHPAD program group (Windows '95).

After loading, BUGS SCRATCHPAD presents the main window. The program is
ready to accept input for a new simulation.

2. Define the Aquifer Grid Mesh.
The first thing to is to define the size and shape of the aquifer mesh. This is done
from the Aquifer Parameters window. To bring up this window select Aquifer
Properties from the Window menu.
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The Aquifer Parameters window will appear. The grid mesh spacing is 1.0
meters, which is the same as the default (the dX field). However, the number of
nodes in the X direction needs to be changed to 100 (the X field). This will result
in an aquifer length of 100 meters. (100 nodes spaced 1 meter apart).

Also notice, the Time group, this is where the starting and ending times for the
simulation are entered. Also, the Step field refers the timestep in which results
are recorded. (The default is for recording the results every 1 time unit.) Since
the default values are the same used for this tutorial, they do not need to be
modified.

The Default System will be explained later below.

Close the Aquifer Parameters window.

3. Add the Conservative Solute
The next step is to add the Conservative Solute. This will be done from the
Parameters window. To display the Parameters window, select Parameters
from the Window window.
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The Parameters window will appear.

Parameters represent many things in a BUGS SCRATCHPAD simulation. They can
represent system defined data such as porosity, hydraulic head, as well as user
defined solutes and sorbed species. They are grouped together as "Parameters"
for the convenience of providing a uniform method to enter simulation initial
values.

The first thing to do is add the conservative solute. This will be a user defined
parameter. To add the parameter, click on the Add button.

The New Parameter dialog box will appear. Enter "O2" as the name for the new
parameter (conservative solute) and click the OK button.

The Parameters window will change to the following.
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The default parameter type for a user parameter is an Imobile parameter (sorbed
species). This needs to be changed to a Mobile parameter (mobile solute
species). To change the new parameter from a Imobile to a Mobile parameter,
first make sure that "O2" is selected in the list box, then check the Mobile
Parameter checkbox.

The Parameters window expands to show some additional data entry fields for a
mobile parameter (solute species).

Al, At, and D* are the longitudinal dispersitivity, transverse dispersitivity, and
effective diffusion coefficients respectively. Change the default values of the
longitudinal and transverse dispersitivity to 1.0 and 0.1 respectively. The effect
of diffusion is ignored in this simulation.
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Close the Parameters window.

4. Create the Boundary Condition "Reaction"
Next, it is necessary to create the constant source boundary condition. In BUGS
SCRATCHPAD, boundary conditions are entered a bit differently than in
traditional groundwater modeling programs. BUGS SCRATCHPAD represents
boundary conditions using Reactions. The primary way BUGS SCRATCHPAD
manipulates the values of parameters in a simulation is through Reactions,
therefore it makes sense to describe a constant source boundary condition
through a Reaction. This opens the door to many possibilities with specialized
boundary conditions. For example, BUGS SCRATCHPAD provides a Reaction that
is dependent upon the simulation time, thus a timed pulsing nutrient injection
well boundary condition can be represented by a reaction almost as easily as a
constant source can be, as in this simulation.

To create the reaction to represent the constant source boundary, select
Reactions from the Window menu.

Since this as a new simulation, no reactions have been defined yet. BUGS
SCRATCHPAD immediately prompts for a new reaction name.

Enter "Constant Source" for the name of the reaction and press the OK button.
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BUGS SCRATCHPAD displays the Reactions window with the "Constant Source"
reaction highlighted in the list box.

Since the Type tab in the Reactions window is already activated, the window
displays the available types of reactions. The default is Standard Equilibrium.
The type of reaction used to represent a constant source is the Equality
Equilibrium reaction. This type of reaction is the simplest of all reactions that
BUGS SCRATCHPAD provides. It simply adjusts the value of a parameter to the
set value at every timestep (just what a constant source does).

To select the Equality Equilibrium, click on the Equality in the Equilibrium
group.

Now to show the window to describe the details of this constant source reaction,
click the Rate tab.
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This reaction allows the user to specify that a parameter will be adjusted to equal
a value defined by a linear combination of all the available parameters at that
node. However, this simulation is only interested in a constant value, so this
extra ability will be ignored for now. The only two data values that need to be
entered are the dependent parameter (O2) and the value to set the dependent
parameter to (10).

In the Depndt. combo box, select "O2".

In the Coeffient. field, enter "10".

Notice that BUGS SCRATCHPAD echoes the equality reaction equation as it is
being built in the window below the Coefficnt. field. (O2 = 10).

This is all that needs to be done with this window, the Systems tab will not be
used at this time. Reaction Systems are explained below.

Close the Reactions window.

5. Create the Reaction Systems
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Reaction Systems are the means by which the user tells BUGS SCRATCHPAD
which reactions occur at which nodes in an aquifer simulation. They allow the
user to group different sets of reactions and name the set of reactions. Then the
user tells BUGS SCRATCHPAD that this collection of reactions occurs at a
particular region in the aquifer. A Reaction can belong to any number of
Reaction Systems but only one Reaction System can occur at any one node.

This particular simulation requires two Reaction Systems. One for the boundary
condition, and one for the remainder of the aquifer.

To bring up the Reaction Systems window, select Reaction Systems from the
Window menu.

Since this as a new simulation, no Reaction Systems have been defined yet.
BUGS SCRATCHPAD immediately prompts for a new Reaction System name.

Enter "Boundary Condition" for the new Reaction System name and press the
OK button.

BUGS SCRATCHPAD displays the Reaction Systems window with the "Boundary
Condition" Reaction System highlighted in the list box.
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Notice that the "Constant Source" Reaction is also displayed in the Not Included
list. This means that "Constant Source" is not included in the "Boundary
Condition" Reaction System. This needs to be changed. To include the "Constant
Source" Reaction in the "Boundary Condition" Reaction System, first click on
"Constant Source" in the Not Included list ("Boundary Condition is already

selected) and click on the button. The reaction now appears in the Included
list.

The "Boundary Condition" Reaction System will be placed at the inlet node, as
described later. Now it is necessary to define the Reaction System that will
represent the remainder of the aquifer. Since this is a conservative tracer
simulation, the second reaction system will contain now reactions, but it still
must be defined anyway.

Click on the Add button to bring up the New Reaction System Dialog. Enter
"Interior" for the name of the new Reaction System and press the OK button.
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The "Interior" Reaction System will reside at every node in the aquifer except for
the inlet. Therefore it will become the Default System (so that each node does
not have to be specifically assigned this reaction system). Check the Use This
Reaction System as Default checkbox at the bottom of the Reaction Systems
window.

Close the Reaction Systems window.

6. Assign Reaction Systems to Nodes
The next step is to tell BUGS SCRATCHPAD where the reaction systems are
located in the aquifer. This is done through the Nodes window.

To bring up the Nodes window, select Nodes from the Window menu.

BUGS SCRATCHPAD will display the Nodes window.
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The Nodes window provides the interface for the user to tell BUGS SCRATCHPAD
which Reaction Systems occur at which nodes in the aquifer. Since constant
source the boundary condition occurs only at the aquifer "inlet" (node 1), this
well be an easy task. The current node is already set at coordinate (1,1) which
will be the inlet node for the aquifer. To change the default Reaction System for
this node, select "Boundary Condition" from the System field.

Since "Interior" is the default Reaction System, the rest of the nodes will use
"Interior" as their Reaction System.

Leave the Nodes window open for the next step.

7. Set the Hydraulic Flow Conditions.
The last data entry step is entering data on the flow conditions. The desired pore
water velocity is 2.0 m/d. Since the effective porosity is 0.5, this would
correspond to a darcy velocity of 1.0 m/d. Since hydraulic conductivity was not
given, (nor is it important for this tutorial) we'll assume it to be 1.0 m/d,
resulting in a desired head gradient of 1.0 m/m. Now assuming a free outlet
condition at the end of the aquifer, and a relative head of 0.0 m; the head at the
entry of the aquifer would be 99 m. (Since node coordinates are block centered,
the actual distance is 99 m between end nodes for this simulation.)
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Therefore, to set the desired flow conditions, the initial hydraulic heads at both
ends of the aquifer should be entered, and BUGS SCRATCHPAD should be
notified that both end nodes in the aquifer are Prescribed Head nodes.

Since the current node is (1,1), it is easy to start there. To notify BUGS
SCRATCHPAD that this is a Prescribed Head node, check the Prescribed Head
checkbox.

Next, With Parameter selected to hydraulic head ("H"), enter "99" in the Value
field in the Initial Parameter Values group.

Next, BUGS SCRATCHPAD needs to be told that the outlet node is also a
prescribed head. Change the coordinates to node (100,1). (A trick is to click on
the up arrow in the spin control for X, it will automatically wrap around to the
end of the aquifer).

As before, check the Prescribed Head checkbox.

Now the necessary information for the flow conditions has been entered (The
default hydraulic head value at the end node is 0, so there is no need to change
it). BUGS SCRATCHPAD will automatically calculate the hydraulic heads and
flow field for the remainder of the nodes in the aquifer grid during calculation
initialization.

Close the Nodes window.



57
8. Save the Project File

Before running an aquifer simulation in BUGS SCRATCHPAD, the project file
must be saved. To save the file, select Save from the File menu.

The user will be prompted with the standard windows save dialog. Enter
whatever is appropriate for your system and press OK.

9. Run the Simulation
The next step is to run the simulation, and save the file afterwards. To run the
simulation select Simulate from the Run menu.

BUGS SCRATCHPAD launches a separate calculation program and waits for its
termination.
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Save the file by selecting Save from the File menu.

Now the results of this simulation can be viewed.

10. Viewing Results
BUGS SCRATCHPAD provides two primary ways to view results, table output and
graphs. The output graphs come in two varieties as well, profile and node. The
profile graphs show concentration profiles through the aquifer at a given point in
time. The node graphs plot the concentration value over time at a single location
within the aquifer.

To view a profile graph, select Profile Graph from the Window menu.
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BUGS SCRATCHPAD displays the Profile Graph in the default configuration.

The profile of hydraulic head is not all that interesting, lets look at the
conservative solute profile at the ending timestep.

From the Parameters select "O2" and then un-select "H".

Now, slide the scroll bar all the way to the right to select the last timestep.

The Profile Graph is now configured to show the concentration profile at the
last timestep.
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To review tabular results, select Output from the Window menu. Viewing
various results in this window is left for the reader to discover. However, it is
worth mentioning that the output grid can be configured by draging lables
around via. Windows Drag and Drop. Poke around a bit to see how it works.
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13.2 Lesson 2, Kinetic Sorption and Desorption

This lesson will demonstrate how to add a partitioning reaction to a simulation. This
lesson uses the simulation created in Lesson One. If the simulation in lesson one is still
open, close all windows and save it. If it is not open, then open it with the Open
command from the file menu.

First, save the simulation under another name. From the File menu, select Save As. In
the save as dialog box enter any appropriate name, for example “Lesson2”.

It is necessary to add a parameter to the simulation to represent the sorbed phase of O2.
From the Windows menu, select Parameters.

Click the Add button and enter “O2 (s)” as the name of the new parameter (sorbed
species.)
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This is an immobile (sorbed) parameter, therefore all the default values are adequate.
Close the Parameters window. From the Windows menu, select Reactions.

Next we’ll add a reaction representing the partitioning of the solute and sorbed phase
(partitioning “O2” and “O2 (s)”). Click on the Add Button and enter “O2 Partitioning”
as the name of the reaction.

This reaction will be a kinetic linear isotherm partitioning reaction. Bring up the Type
screen by clicking on the Type tab if necessary.

Select Linear under the Kinetic Sorption reaction type.

Next we’ll add the rate data for the partitioning reaction. Select the Rate tab.

The rate data will appear. The linear driving force will be a one to one ratio between
“O2” and “O2 (s)”. Enter values so that they match the following example.
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Now that the rate data is entered, enter the Stoichiometry data. Click on the
Stoichiometry tab.

The solute, O2, will be moving to the Sorbed phase, O2 (s), when the rate is positive.
For O2 enter -1.0. For O2 (s) enter 1.0.

BUGS will then display the Stoichiometry reaction.

Next, add this reaction to the entire aquifer system. Click on the Systems tab.

To include this reaction in all of the reaction systems, click on the include all button,
this includes the reaction in both the “Boundary Condition” reaction system and
“Interior” reactions system.

Now this reaction will be included both in the boundary condition reaction system and
the interior reaction system.

Close the reactions window. Save the simulation data before running the simulation. A
shortcut way of saving a simulation is to click the Save button on the tool bar.

Run the simulation, chose Simulate from the Run Menu
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The screen will appear similar to the following.

To view the profile output select Profile Graph from the Windows menu. From the
Parameters menu ensure O2 and O2 (s) are checked. Move the time period to 7. The
graph should appear to be similar to the following.

Notice, the O2 (s) front lags behind the O2 Solute front, as it should with kinetic
sorption.

This concludes lesson two.
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13.3 Lesson 3, First Order Decay

This lesson demonstrates how to set the default initial value of a parameter and add first
order decay to a simulation. This lesson uses the simulation created in lesson one. If the
simulation in lesson one is still open, close all windows and save it. If it is not open,
then open it with the Open command from the file menu.

Save the simulation under another name. From the File menu, select Save As. In the
save as dialog box enter any appropriate name, for example “Lesson3”.

For this simulation, the aquifer will have an initial uniform concentration of O2 of 10
throughout the aquifer. From the Windows menu, Select Parameters.

Select “O2” in the list box and then enter a default concentration of 10.

A first order decay reaction will be added to the simulation. From the Windows menu,
select Reactions.
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Click the Add button and enter “Decay” as the name for the new reaction.

Click on the Type Tab to bring up the type information screen if necessary:

Select the first order reaction option.

Now, enter rate data. Click on the Rate tab.

The first order reaction will have a rate constant of 0.5, enter the values on the screen as
they appear below.

Now, define the Stoichiometry for the reaction. Click on the Stoichiometry tab.

“O2” will be decaying to nothing. Enter -1 for the coefficient for O2.

BUGS will echo the Stoichiometry reaction.
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Add this reaction to a reaction system. Click on the Systems tab.

Select “Interior” in the unused list box

and click the include button.

The simulation is now ready to run. Close the reactions window and save the file.

or

Select Simulate from the Run menu:

When the simulation is done, save the file once again. Now, from the Windows menu
select Profile Graph. Below is an example of the O2 profile at timestep seven.

This concludes lesson 3.
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13.4 Lesson 4, Two Dimensional Tracer Simulation

This lesson explains how to expand a one dimensional simulation into a two
dimensional simulation. This lesson uses the simulation created in lesson one. If the
simulation in lesson one is still open, close all windows and save it. If it is not open,
open it with the Open command from the file menu.

First, expand the aquifer size. From the Windows menu, select Aquifer Properties.

In the number of Y coordinates box, enter 30.

All other values are satisfactory. Close the window. A uniform velocity in the X
direction will be used for this simulation. From the Windows menu, select Nodes.

Change all of the coordinates along the Y axis where X is 1. For each node along the Y
axis where X is 1, ensure the prescribed check box is checked, and the value of head is
100. (This is the time consuming way of doing it, for quicker ways of entering
prescribed conditions, see Specifying Initial Values of Parameters.)
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and  and

Each node along the Y axis where X = 100 must be set to a prescribed head as well. The
value for prescribed head of zero need not be changed.

and 

Next, the constant source will be moved to the middle of the edge of the aquifer. The
reaction system at node (1,1) should be set to “Interior”

and the reaction system at node (1,15) should be set to “Boundary Condition”.

and 
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All the necessary changes have been made, save the file as “lesson4.bgs” and run the
simulation. When the simulation is done, select Surface Graph from the Windows
menu. Then ensure O2 is checked in the Parameters menu. The surface plot of O2 at
time period 7 is

This concludes lesson 4.
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15. Index

— A—
Alias, 10
Aquifer, 7
Aquifer Simulation, 7
Aquifer System, 13

Mesh, 14
Size and Discretization, 13

— C—
Clipboard, 36
Command Keys, 42
Competitive Inhibition Reaction, 27
Conservative Solute. See Examples and Lessons

— D—
Double Monod Reaction, 26

— E—
Equality Reaction, 21
Equilibrium Reaction, 21

— F—
Files

Intermediate, 11
First Order Decay. See Quick Start
Fredulich Equilibrium Reaction, 24
Fredulich Kinetic Isotherm Reaction, 25

— I—
Installation, 6

— L—
Langmuir Equilibrium Reaction, 23
Langmuir Kinetic Isotherm Reaction, 25
Linear Kinetic Isotherm Reaction, 24
Linear Sorption Reaction, 23

— M—
Mass Transfer Reaction, 27
Menus, 38

Edit, 38
File, 38
Parameters, 39

Run, 39
View, 39
Window, 40

Mixed Ordered Reaction, 22

— O—
Output

File Format, 36
Node Time Series Graph, 33
Parameter Profile Graph, 32
Surface Plot, 33
Tabular, 34
Viewing, 32

— P—
Parameters, 8

Adding and Removing, 14
Initial Value, 16
Menu, 39
Mobile and Immobile, 15

— R—
Reaction System, 9
Reaction Systems, 28

Adding and Deleting, 29
Default, 30
Specifying Reactions, 30

Reaction Systems Window, 29
Reactions, 9

Adding and Removing, 18
Editing, 17
Equilibrium, 9
Kinetic, 9
Reactions Window, 17
Specifying Reaction Systems, 19
Stoichiometry, 9, 19
Type, 18
Types, 20

References, 71
Rule Curve Reaction, 28

— S—
Shortcut Keys. See Command Keys
Simulation

Running, 31
Simulation Options, 30
Simulation Time, 13
Single Monod Reaction, 26
Single Order Reaction, 22
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Sorption and Desorption, 61

— T—
Toolbar, 41

— V—
Views

Form, 12
Grid, 12
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